Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).
But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
题意:
从序列中截取不相交的 m 段连续子段,求最大和
思路:
(1)子问题:第 j 个位置前截取 i 段的最大值
(2)状态:dp[i][j],表示第 j 个位置前截取 i 段的最大值
(3)状态转移方程:dp[i][j] = max(dp[i][j], dp[i - 1][k] + a[j], dp[i][j - 1] + a[j]); k 属于[i - 1, j - 1]
令pre[j - 1] = dp[i - 1][k],状态转移方程变为 dp[j] = max(dp[j - 1], pre[j - 1]) + a[j]
不要忘了剪枝!!!
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod = 1e9 +7;
const int inf = 0x3f3f3f3f;
const int N = 1e6 + 10;
int dp[N];
int pre[N];
int a[N];
int main()
{
int n, m;
while(~scanf("%d%d", &m, &n))
{
for(int i = 1; i <= n; ++i)
{
scanf("%d", &a[i]);
}
memset(dp, 0, sizeof(dp));
memset(pre, 0, sizeof(pre));
int maxx = -inf;
// dp[i][j] = max(dp[i][j], dp[i - 1][k] + a[j], dp[i][j - 1] + a[j]);
for(int i = 1; i <= m; ++i) ///m段
{
maxx = -inf;
for(int j = i; j <= n; ++j) ///在[0, j]内截了i段
{
dp[j] = max(pre[j - 1], dp[j - 1]) + a[j];
pre[j - 1] = maxx;
maxx = max(maxx, dp[j]);
}
}
cout<<maxx<<'\n';
}
return 0;
}