<center> 4079.   find the princessII
Time Limit: 1.0 Seconds    Memory Limit:65536K
Total Runs: 255    Accepted Runs:179 </center>


After Dsir through the "find the princessI". He came to the front door. He must go through this door can save the princess. But there is a combination lock the door. On the door there is a problem, can open the door only correct answer. This problem is that there were two smart people, Hacb and GDRTOP. They are very clever. They're playing a game, There are n sticks. They take turns to take stick.The loser is who took away the last stick. There are some rules: if there are n sticks, players can only take x sticks. Pay attention to n % x = 0.
In this game, Hacb always first take the stick.

Input

There are some cases. Each line of input n. (the number of the sticks)

Output

output "H" if Hacb win , Otherwise, output "G".

Sample Input

1
2

Sample Output

G
H


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;

int main(){
	int n;
	while(~scanf("%d",&n)){
		if(n%2==0){
			printf("H\n");
		}
		else printf("G\n");
	}
	return 0;
}