题干:

DreamGrid has just found an integer sequence  in his right pocket. As DreamGrid is bored, he decides to play with the sequence. He can perform the following operation any number of times (including zero time): select an element and move it to the beginning of the sequence.

What's the minimum number of operations needed to make the sequence non-decreasing?

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer  (), indicating the length of the sequence.

The second line contains  integers  (), indicating the given sequence.

It's guaranteed that the sum of  of all test cases will not exceed .

Output

For each test case output one line containing one integer, indicating the answer.

Sample Input

2
4
1 3 2 4
5
2 3 3 5 5

Sample Output

2
0

Hint

For the first sample test case, move the 3rd element to the front (so the sequence become {2, 1, 3, 4}), then move the 2nd element to the front (so the sequence become {1, 2, 3, 4}). Now the sequence is non-decreasing.

For the second sample test case, as the sequence is already sorted, no operation is needed.

解题报告:

排好序就确定了他最终的状态,找到每个值最终出现的位置就行了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
int a[MAX],b[MAX];
int n;
int main()
{
	int t;
	cin>>t;
	while(t--) {
		scanf("%d",&n);
		for(int i = 1; i<=n; i++) {
			scanf("%d",a+i);b[i] = a[i];
		}
		sort(b+1,b+n+1);
		int all = 0;
		for(int i = n; i>=1; i--) {
			if(a[i] == b[i+all]) continue;
			else all++;
		}
		printf("%d\n",all);
	}
	return 0 ;
 }
/*
100
5
1 2 2 5 1
1 1 2 2 5
*/