题干:

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

CTU Open 2003

 

题意:

      给出 n 种卡车,每种卡车的类型是由七个字符组成的,一种卡车可以从另一种卡车派生而来,所需要的代价是两种卡车类型不同的字符个数,求出这 n 种卡车派生的最小代价, n 种车有一 种是开始就已经有的,其余的 n-1 种是派生出来的。

      用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数。一个编号只能由另一个编号“衍生”出来,代价是这两个编号之间相应的distance,现在要找出一个“衍生”方案,使得总代价最小,也就是distance之和最小。

解题报告:

读入字符串后先将字符串处理一下,并将权值算好后 入node结构体,然后对结构体排序等等 就是最小生成树裸题了。

ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAX = 10000 + 5 ;

int f[MAX+5];
int n;
char s[MAX + 5][10];
int ans;
int top;
struct Node {
	int u,v,dist;
} node[50000000 + 5];

int getf(int v) {
	return f[v] == v ? v : f[v] = getf(f[v] );
}
void merge(int u, int v) {
	int t1 = getf(u );
	int t2 = getf(v );
	if(t1 != t2) {
		f[t2] =t1;
	}
	
}
bool cmp(const Node & a,const Node & b) {
	return a.dist<b.dist;
}
int main()
{
	int sum;
	while(scanf("%d",&n) && n ) {
		for(int i = 0 ; i<=n; i++) {
			f[i]=i;
		}
		ans = 0;top = 0;
		for(int i = 1; i<=n; i++) {
			scanf("%s",s[i]);
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				sum = 0;
				for(int k = 0 ; k<7; k++) {
					if(s[i][k]!=s[j][k] ) sum++;
				}
				++top;
				node[top].u = i;node[top].v = j;node[top].dist = sum;
//				merge(i,j);
			}
		}
		sort(node+1,node+top+1,cmp);
		int m=0;//代表边数 
		for(int i = 1; i<=top; i++) {
			if(getf(node[i].u) != getf(node[i].v) ) {
				ans +=node[i].dist;
				merge(node[i].u,node[i].v);
				m++;
				if(m== n-1) break;
			}
			
		}
		printf("The highest possible quality is 1/%d.\n",ans);			
	}
	
	return 0 ;
	
}

总结:

    1.这波太难受了啊。  

          1RE。因为读字符串的时候i<=MAX了!这样是不对的,因为开的数组大小是MAX所以这里不能小于等于!所以最好就是读数据的时候写<=n,别太洋气的写<=MAX,如果要这么写的话,你开数组就得写MAX+c了!并且发现top和ans没有初始化。

           2RE。因为数组开小了。node数组应该开MAX*MAX+c!

           3WA。因为输出格式不对。。。。少了个句点你能信。、。。

           4AC    

   2. 我们来算一下时间复杂度吧。你在读数据后遍历的时候, 两层for循环到n,所以时间复杂度是n^2的还可以。加一个克鲁斯科尔 排序 o(eloge)+遍历o(e)的。