http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3175
For two integers m and k, k is said to be a container of m if k is divisible by m. Given 2 positive integers n and m (m < n), the function f(n, m) is defined to be the number of containers of m which are also no greater than n. For example, f(5, 1)=4, f(8, 2)=3, f(7, 3)=1, f(5, 4)=0...
Let us define another function F(n) by the following equation:
Now given a positive integer n, you are supposed to calculate the value of F( n).
Input
There are multiple test cases. The first line of input contains an integer T(T<=200) indicating the number of test cases. Then T test cases follow.
Each test case contains a positive integer n (0 < n <= 2000000000) in a single line.
Output
For each test case, output the result F(n) in a single line.
Sample Input
2
1
4
Sample Output
0
4
题意:求n/1+n/2+n/3+……+n/n-n的值
思路:n很大,只有优化到根号N才能做,怎么优化呢?
题解:https://www.cnblogs.com/ZP-Better/p/4639596.html
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<map>
#include<vector>
#include<set>
#include<list>
#include<stack>
#include<queue>
using namespace std;
typedef long long ll;
int main(){
int T;
scanf("%d",&T);
while(T--){
ll n;
scanf("%lld",&n);
ll q=(ll)sqrt(n);
ll sum=0;
for(int i=1;i<=q;i++){
sum+=n/i;
}
printf("%lld\n",sum*2-q*q-n);
}
return 0;
}
分块
#include<cstdio>
using namespace std;
typedef long long ll;
int main(){
int T;
scanf("%d",&T);
while(T--){
int n;
scanf("%d",&n);
ll ans=0;
for(int l=1,r;l<=n;l=r+1){
r=n/(n/l);
ans+=(ll)(n/l)*(r-l+1);
}
printf("%lld\n",ans-n);
}
return 0;
}