题目

有一种酒桌游戏叫做“敲7”,规则是从一个人开始,说出任意数字,其他人会顺序往后报,如果一个数字包含 <math> <semantics> <mrow> <mn> 7 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 7 </annotation> </semantics> </math>7,或者是 <math> <semantics> <mrow> <mn> 7 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 7 </annotation> </semantics> </math>7 的倍数,那么需要敲打杯子或盘子,不能说出。

现在 <math> <semantics> <mrow> <mi> n </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> n </annotation> </semantics> </math>n 个人围坐在一个圆桌周围,他们编号从 <math> <semantics> <mrow> <mn> 1 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 1 </annotation> </semantics> </math>1 <math> <semantics> <mrow> <mi> n </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> n </annotation> </semantics> </math>n 顺时针排列。从某一人开始报出一个数字,其他人会按照顺时针方向顺序往后报(加一),如果某个人的数字包含 <math> <semantics> <mrow> <mn> 7 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 7 </annotation> </semantics> </math>7,或者是 <math> <semantics> <mrow> <mn> 7 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 7 </annotation> </semantics> </math>7 的倍数,那么他将退出游戏,下一个人继续接着报,直到剩一个人为止。

输入格式

第一行输入三个整数, <math> <semantics> <mrow> <mi> n </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> n </annotation> </semantics> </math>n <math> <semantics> <mrow> <mi> m </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> m </annotation> </semantics> </math>m <math> <semantics> <mrow> <mi> t </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> t </annotation> </semantics> </math>t <math> <semantics> <mrow> <mi> n </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> n </annotation> </semantics> </math>n 代表总人数, <math> <semantics> <mrow> <mi> m </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> m </annotation> </semantics> </math>m 代表从第 <math> <semantics> <mrow> <mi> m </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> m </annotation> </semantics> </math>m 个人开始报数,他报出的数字是 <math> <semantics> <mrow> <mi> t </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> t </annotation> </semantics> </math>t。( <math> <semantics> <mrow> <mn> 1 </mn> <mo> ≤ </mo> <mi> m </mi> <mo> ≤ </mo> <mi> n </mi> <mo> ≤ </mo> <mn> 1000 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 1 \leq m \leq n \leq 1000 </annotation> </semantics> </math>1mn1000 <math> <semantics> <mrow> <mn> 1 </mn> <mo> ≤ </mo> <mi> t </mi> <mo> ≤ </mo> <mn> 100 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 1 \leq t \leq 100 </annotation> </semantics> </math>1t100)接下来的 <math> <semantics> <mrow> <mi> n </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> n </annotation> </semantics> </math>n 行,每一行输入一个字符串,代表这 <math> <semantics> <mrow> <mi> n </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> n </annotation> </semantics> </math>n 个人的名字,字符串的长度不超过 <math> <semantics> <mrow> <mn> 20 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 20 </annotation> </semantics> </math>20

输出格式

输出剩下的那个人的名字,占一行。

样例输入

5 3 20

donglali

nanlali

xilali

beilali

chuanpu

样例输出

chuanpu

题解

每当数到符合条件的数踢出去

#include<iostream>
#include<string>
#include<queue>
using namespace std;
bool judge(int t){
	if(t%7 == 0)
		return true;
	while(t){
		if(t%10==7)
			return true;
		t /= 10;
	}
	return false;
}
int main(){
	queue<string> q;
	int n,m,t;
	string name;
	cin>>n>>m>>t;
	for(int i=0;i<n;i++){
		cin>>name;
		q.push(name);
	}
	for(int i=0;i<m-1;i++){ // 数前面 m-1 个 
		name = q.front();
		q.pop();
		q.push(name);
	}
	// 从第 m 个开始 
	while(q.size() != 1){
		name = q.front();
		q.pop();
		if(!judge(t++))   // 如果符合条件就不加到队列末尾 
			q.push(name);
	}
	cout<<q.front();
	return 0;
}

返回目录,查看更多