Simpsons’ Hidden Talents

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton

homer

riemann

marjorie

Sample Output

0

rie 3

题意描述:

求出字符A的前缀与字符串B后缀相同的长度并输出。

解题思路:

求出字符串A的next[]数组,利用kmp算法查找当字符串B查找结束时字符串A能查找到的位置,并输出。

#include<stdio.h>
#include<string.h>
int next[100010];
char a[100010],b[100010];
void get_next(char s[])
{
	int i,j,len;
	len=strlen(s);
	j=0;
	i=1;
	next[0]=0;
	while(i<len)
	{
		if(s[i]==s[j])
		{
			next[i]=j+1;
			i++;
			j++;
		}
		if(j==0&&s[i]!=s[j])
		{
			next[i]=0;
			i++;
		}
		if(j>0&&s[i]!=s[j])
		{
			j=next[j-1];
		}
	}
}
int kmp(char s1[],char s2[])
{
	get_next(s2);
	int i,j,len1,len2;
	len1=strlen(s1);
	len2=strlen(s2);
	i=0;
	j=0;
	while(i<=len1)
	{
		if(s1[i]==s2[j])
		{
			j++;
			if(j==len2)
			{
				if(i==len1-1)
					return j;
				j=next[j-1];
			}
			i++;
		}
		if(i==len1)
			return j;
		if(j==0&&s1[i]!=s2[j])
			i++;
		if(i==len1)
			return j;
		if(j>0&&s1[i]!=s2[j])
			j=next[j-1];
	}
}
int main()
{
	int x,i;
	while(gets(a)!=NULL)
	{
		gets(b);
		x=kmp(b,a);
		if(x==0)
			printf("0\n");
		else
		{
			for(i=0;i<x;i++)
				printf("%c",a[i]);
			printf(" %d\n",x);
		}
	}
	return 0;
}