题目链接:https://vjudge.net/problem/HDU-1358

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:求出所有前缀(满足是两个或两个以上的循环节组成的字符串)

           输出前缀的位置[0-i-1]的i,以及循环节的个数

循环节不会求的可以看这篇博客https://blog.csdn.net/qq_42936517/article/details/86760809

#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e6+5;
char s[N];
int next[N];
void getnext(int len) {
	int j=-1;
	next[0]=-1;
	for(int i=1; i<len; i++) {
		while(j!=-1&&s[i]!=s[j+1])
			j=next[j];
		if(s[i]==s[j+1])
			j++;
		next[i]=j;
	}
}
int main() {
    int n;
    int Case=0;
    while(scanf("%d",&n)&&n){
    	scanf("%s",s);
    	getnext(n);
//    	for(int i=0;i<n;i++)
//    	printf("%d%c",next[i]," \n"[i==n-1]);
    	printf("Test case #%d\n",++Case);
    	for(int i=1;i<n;i++){
    		int len=i+1;
    		int x=len-next[i]-1;
    		if(len%x==0&&len/x>1)
    		printf("%d %d\n",i+1,len/x);
		}
		printf("\n");
	}
	return 0;
}