题干:
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Output
For each test case, output one integer, indicating maximum value iSea could get.
Sample Input
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
Sample Output
5 11
题目大意:
给你一些钱 m ,然后在这个国家买东西, 共有 n 件物品,每件物品有 价格 P 价值 V 还有一个很特别的属性 Q, Q 指 你如过想买这件物品 你的手中至少有这钱Q 。 虽然你只要花费 钱P ,但你的手中至少有钱Q,如果不足Q ,不能买。问给你钱M ,列出N件物品,最多能获得多少价值的东西。。。。
解题报告:
先排序,然后跑一边0-1背包即可。这个排序很巧妙啊
AC代码:
#include<bits/stdc++.h>
using namespace std;
struct Node {
int p,q,v;
} node[500 + 5];
int dp[5000 + 5];
bool cmp(const Node & a,const Node & b) {
return a.q-a.p<b.q-b.p;//b.q+a.p>b.p+a.q
}
int main()
{
int n,m;
while(cin>>n>>m) {
for(int i = 1; i<=n; i++) {
scanf("%d%d%d",&node[i].p,&node[i].q,&node[i].v);
}
memset(dp,0,sizeof(dp));
sort(node+1,node+n+1,cmp);
for(int i = 1; i<=n; i++) {
for(int j = m;j >=max(node[i].q,node[i].p); j--) {
dp[j] = max(dp[j],dp[j-node[i].p ] + node[i].v);
}
}
printf("%d\n",dp[m]);
}
return 0;
}