blockhouses
时间限制:1000 ms  |            内存限制:65535 KB
难度:3

描述
    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

 

    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

    输入
        The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
    输出
        For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.


    样例输入

        4
        .X..
        ....
        XX..
        ....
        2
        XX
        .X
        3
        .X.
        X.X
        .X.
        3
        ...
        .XX
        .XX
        4
        ....
        ....
        ....
        ....
        0

    样例输出

        5
        1
        5
        2
        4

题目大意:给出一个地图,x表示墙,任何武器都不能穿过,.表示空地,在空地上可以建炮楼,每个炮楼都可以攻击到东西南北方向上的炮楼,前提是不能有墙挡着,在各个炮楼不能相互攻击的情况下,最多能建多少个炮楼。

分析:题目类似于8皇后问题,我们直接在空地上填上炮楼,使之不与左边和上边的冲突即可。中间记录最大的值。

 

代码:
 

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
int max=0,n,m,sum=0;char a[100][100]={'\0'};
int pd(int x,int y,char a[100][100])//只要判断前面和上面
{
    if(a[x][y]=='X') return 0;
    for(int i=x-1;i>=0;i--)
    {
        if(a[i][y]=='o') return 0;
        if(a[i][y]=='X') break;
    }
    for(int i=y-1;i>=0;i--)
    {
        if(a[x][i]=='o') return 0;
        if(a[x][i]=='X') break;
    }
    return 1;
}
void dfs(int x,int y)
{
    int z=sum;
    if(x==n-1&&y==n)
    {
        if(z>max)
        {
            max=z;
            /*for(int i=0;i<n;i++) printf("%s\n",a[i]);
            printf("\n\n");*/
        }
        return;
    }
    if(x>=n||y>=n) return;
        if(pd(x,y,a)==1)
        {
            a[x][y]='o';
            sum+=1;
            dfs(x,y+1);//从当前位置一直到结束,
            dfs(x+1,0);
            a[x][y]='.';//此时的xy还是未搜素的xy
            sum-=1;
        }
        dfs(x,y+1);//搜索完一行继续下一行搜索
        dfs(x+1,0);
        return;
}
int main()
{
    while(1)
    {
        memset(a,'\0',sizeof(a));//不清零会有bug
        scanf("%d",&n);
        max=0;sum=0;
        getchar();
        if(n==0) break;
        for(int i=0;i<n;i++)
        {
            scanf("%s",a[i]);
            getchar();
        }
        dfs(0,0);
        printf("%d\n",max);
    }
    return 0;
}