数列两段的最大字段和

POJ2479

Maximum sum

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41231 Accepted: 12879

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:

Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
Huge input,scanf is recommended.

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn = 50000+7;

int t,n,arr[maxn],sum;
int a[maxn],b[maxn];

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i = 1; i <= n ; i++ ) {
            scanf("%d",&arr[i]);
        }
        a[1] = arr[1];
        for(int i = 2; i <= n; i ++ ) {
            if(a[i-1]<0)
                a[i]=arr[i];
            else
                a[i]= a[i-1]+arr[i];
        }
        for(int i = 2; i <= n; i ++ ) {
            a[i] = max(a[i-1],a[i]);
        }
        /*********************************/
        b[n] = arr[n];
        for(int i = n-1; i >= 1; i -- ) {
            if(b[i+1]<0)
                b[i]=arr[i];
            else
                b[i]= b[i+1]+arr[i];
        }
        for(int i = n-1; i >= 1; i -- ) {
            b[i] = max(b[i+1],b[i]);
        }
        int ans = -999999999;
        for(int i = 2; i <= n; i ++ ) {
            ans = max(a[i-1]+b[i],ans);
        }
        printf("%d\n",ans);
    }

    return 0;
}

最长公共上升子序列

POJ1458

Common Subsequence

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 53882 Accepted: 22384

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn = 1e3+7;

char str[maxn],ttr[maxn];
int dp[maxn][maxn];

int main()
{
    while(~scanf("%s %s",str+1,ttr+1))
    {
        int n = strlen(str+1);
        int m = strlen(ttr+1);
        memset(dp,0,sizeof(dp));
        dp[1][1] = str[1] == ttr[1];
        for(int i = 1; i <= n; i ++ ) {
            for(int j = 1; j <= m ; j ++ ) {
                if(i == 1 && j == 1) {
                    continue;
                }
                if(str[i] == ttr[j]) {
                    dp[i][j] = dp[i-1][j-1]+1;
                }
                else {
                    dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}

最长上升子序列

POJ2533

Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 53931 Accepted: 24094

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn = 1005;

int n,arr[maxn],dp[maxn];

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i =1 ; i <= n ; i ++ ) {
            scanf("%d",&arr[i]);
            dp[i] = 1;
        }
        for(int i = 1 ; i <= n ; i ++ ) {
            for(int j = 1; j < i ; j ++ ) {
                if(arr[i]>arr[j]) {
                    dp[i] = max(dp[i],dp[j]+1);
                }
            }
        }
        int ans = 0;
        for(int i = 1; i <= n; i ++ ) {
            ans = max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }

    return 0;
}
//二分版本
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn = 1005;

int n,arr[maxn],dp[maxn],top,data;

int main()
{
    while(~scanf("%d",&n))
    {
        top = 1;
        scanf("%d",&dp[0]);
        for(int i =1 ; i < n ; i ++ ) {
            scanf("%d",&data);
            if(data > dp[top-1]) {
                dp[top++] = data;
            }
            else {
                dp[lower_bound(dp,dp+top,data)-dp] = data;
            }
        }
        printf("%d\n",top);
    }

    return 0;
}

最长公共上升子序列

HDU1423

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8181 Accepted Submission(s): 2644

Problem Description

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2
#include <bits/stdc++.h>

using namespace std;
const int maxn = 1005;

int f[maxn];
int a[maxn],n;
int b[maxn],m;

int main()
{
    int t;
    while(~scanf("%d",&t))
    {
        while(t--)
        {

            memset(f,0,sizeof(f));
            scanf("%d",&n);
            for(int i = 1; i <= n; i ++ )
            {
                scanf("%d",&a[i]);
            }
            scanf("%d",&m);
            for(int i = 1; i <= m; i ++ )
            {
                scanf("%d",&b[i]);
            }

            for(int i = 1; i <= n; i ++ )
            {
                int MAX = 0;
                for(int j = 1; j <= m; j ++ )
                {
                    if(a[i] > b[j]) MAX = max(MAX,f[j]);
                    if(a[i] == b[j]) f[j] = MAX + 1;
                }
            }

            int ans = 0;
            for(int j = 1; j <= m; j ++ )
            {
                ans = max(ans,f[j]);
            }
            printf("%d\n",ans);
            if(t){
                puts("");
            }
        }
    }

    return 0;
}