physics

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 526    Accepted Submission(s): 333


Problem Description
There are n balls on a smooth horizontal straight track. The track can be considered to be a number line. The balls can be considered to be particles with the same mass.

At the beginning, ball i is at position Xi. It has an initial velocity of Vi and is moving in direction Di.(Di1,1)
Given a constant C. At any moment, ball its acceleration Ai and velocity Vi have the same direction, and magically satisfy the equation that Ai * Vi = C.
As there are multiple balls, they may collide with each other during the moving. We suppose all collisions are perfectly elastic collisions.

There are multiple queries. Each query consists of two integers t and k. our task is to find out the k-small velocity of all the balls t seconds after the beginning.

* Perfectly elastic collision : A perfectly elastic collision is defined as one in which there is no loss of kinetic energy in the collision.
 

Input
The first line contains an integer T, denoting the number of testcases.

For each testcase, the first line contains two integers n <= 10^5 and C <= 10^9.
n lines follow. The i-th of them contains three integers Vi, Xi, Di. Vi denotes the initial velocity of ball i. Xi denotes the initial position of ball i. Di denotes the direction ball i moves in.

The next line contains an integer q <= 10^5, denoting the number of queries.
q lines follow. Each line contains two integers t <= 10^9 and 1<=k<=n.
1<=Vi<=10^5,1<=Xi<=10^9
 

Output
For each query, print a single line containing the answer with accuracy of 3 decimal digits.
 

Sample Input
1 3 7 3 3 1 3 10 -1 2 7 1 3 2 3 1 2 3 3
 

Sample Output
6.083 4.796 7.141
 

Author
学军中学
 

Source

2016 Multi-University Training Contest 8 


思路:

这道题的题意就是说,给你n个球,知道每个球的初始速度、初始位置、初始方向。问,经过t秒之后的k小的速度。小球之间可以发生完全弹性弹性碰撞,因为小球的质量都相同,所以碰撞之后速度交换。那么这里其实就可以看作是小球之间没有碰撞,因为在小球交换完速度之后就相当于交换完的球替原来的球继续跑。由于题目中给了一个关系式,v*a=c,把a看作dv/dt,那么两边同时积分,就能得出来v和t的关系式。v*v=v0^2+2ct。从而任意小球在任意时刻的位置可以求出,再用一个sort排序求第k小的那个球的速度即可。

这里可以参照编程之美这本书的一道题目——蚂蚁爬杆问题


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=100000+5;
long long n,c;
long long save[maxn];
int main() {
    int t;
    scanf("%d",&t);
    long long vi,xi,di,q;
    long long i,j,k,kill;
    while(t--){
        scanf("%lld%lld",&n,&c);
        for(i=1;i<=n;i++){
            scanf("%lld%lld%lld",&save[i],&xi,&di);
        }
        sort(save+1, save+1+n);
        scanf("%lld",&q);
        for(i=1;i<=q;i++){
            scanf("%lld%lld",&k,&kill);
            double result = sqrt(2*k*c+(save[kill]*save[kill]));
            printf("%.3lf\n",result);
        }
    }
    return 0;
}