题干:

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

解题报告:

     树的直径,裸题。套模板。

AC代码:

#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int MAX = 2e5 + 5 ; 
const int INF = 0x3f3f3f3f;
struct Node {
	int to;
	int w;
	int ne;
} e[MAX];
struct point {
	int pos,c;
	point(){}//没有此构造函数不能写  node t  这样
	point(int pos,int c):pos(pos),c(c){}//可以写node(pos,cost)这样

};
int head[MAX];
int cnt = 0 ;
bool vis[MAX];
void init() {
	cnt = 0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v,int w) {
	e[cnt].to = v;
	e[cnt].w = w;
	e[cnt].ne = head[u];
	head[u] = cnt;
	cnt++;  
} 

int bfs(int x,int &w) {
	queue <point> q;
	int maxx = 0;
	int retp = x;//返回的点坐标 
	memset(vis,0,sizeof(vis) );
	q.push(point(x,0));vis[x] = 1;
	point now;
	while(q.size() ) {
		point cur = q.front();
		q.pop();
		for(int i = head[cur.pos]; i!=-1; i=e[i].ne) {
			if(vis[e[i].to]) continue;
			vis[e[i].to] = 1;
			now.pos = e[i].to;
			now.c = cur.c + e[i].w;
			if(now.c>maxx) {
				maxx = now.c;
				retp = now.pos;
			}
			q.push(now);
		}
		//w = maxx;
		
	}
	w = maxx;
	return retp;
}
int main()
{
	init();
	int u,v,w;
	while(~scanf("%d%d%d",&u,&v,&w) ) {
		add(u,v,w);
		add(v,u,w);
	}
	int ans1 = 0,ans2 = 0;
	u = bfs(1,ans1);
	v = bfs(u,ans2);
	printf("%d\n",ans2);
	
	return 0 ;
}

总结:

   1.  很迷,,,不知道为什么,maxx初始化成-INF,或者retp不初始化成x,都会re。。。。