FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:

给出 n * n 个洞,每个洞中存了g[i][j]的奶酪,一只老鼠从(1, 1)点出发,可以上下左右走,最多连续走 k 步,然后进入一个洞中吃奶酪,后一次吃到的奶酪数必须大于前一次吃到的奶酪数。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const ll mod = 1e9 + 7;
const double eps = 1e-8;
const int N = 110;

int n, k;
int dir[4][2] = {0, 1, 0, -1, 1, 0, -1, 0};
int g[N][N];
int dp[N][N];   ///dp[i][j]:以(i, j)为起点的最大值

int dfs(int x, int y)
{
    if(dp[x][y] > 0)
        return dp[x][y];
    dp[x][y] = g[x][y];
    for(int i = 1; i <= k; ++i) ///枚举步数
    {
        for(int j = 0; j < 4; ++j)
        {
            int tx = x + dir[j][0] * i;
            int ty = y + dir[j][1] * i;
            if(tx < 1 || tx > n || ty < 1 || ty > n || g[tx][ty] <= g[x][y])
                continue;
            dp[x][y] = max(dp[x][y], g[x][y] + dfs(tx, ty));
        }
    }
    return dp[x][y];
}

int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        if(n == -1 && k == -1)
        {
            break;
        }
        for(int i = 1; i <= n; ++i)
        {
            for(int j = 1; j <= n; ++j)
            {
                scanf("%d", &g[i][j]);
            }
        }
        memset(dp, 0, sizeof(dp));
        cout<<dfs(1, 1)<<'\n';
    }
    return 0;
}