题干:

Mr. Frog has two sequences a1,a2,⋯,ana1,a2,⋯,an and b1,b2,⋯,bmb1,b2,⋯,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,⋯,bmb1,b2,⋯,bm is exactly the sequence aq,aq+p,aq+2p,⋯,aq+(m−1)paq,aq+p,aq+2p,⋯,aq+(m−1)p where q+(m−1)p≤nq+(m−1)p≤n and q≥1q≥1.

Input

The first line contains only one integer T≤100T≤100, which indicates the number of test cases. 

Each test case contains three lines. 

The first line contains three space-separated integers 1≤n≤106,1≤m≤1061≤n≤106,1≤m≤106 and 1≤p≤1061≤p≤106. 

The second line contains n integers a1,a2,⋯,an(1≤ai≤109)a1,a2,⋯,an(1≤ai≤109). 

the third line contains m integers b1,b2,⋯,bm(1≤bi≤109)b1,b2,⋯,bm(1≤bi≤109).

Output

For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.

Sample Input

2
6 3 1
1 2 3 1 2 3
1 2 3
6 3 2
1 3 2 2 3 1
1 2 3

Sample Output

Case #1: 2
Case #2: 1

题目大意:

     给两个字符串a和b,大小分别是n和m,a数组以p为步长移动,b数组以1以步长移动,a中有多少个b串。(即数组匹配问题,只不过是a串的步长不是1)

     这题直接暴力o(nm)的复杂度可以过,也可以用KMP算法,一种专门处理字符串匹配问题的算法,处理长串的表现十分优秀,这里不做过多解释。

AC代码:

#include<bits/stdc++.h>
using namespace std;
int n,m,p,ans;
int a[1000000 + 5],b[1000000 + 5];
int main()
{
	int t,iCase = 0,flag;
	cin>>t;
	while(t--) {
		scanf("%d%d%d",&n,&m,&p);
		ans = 0;
		for(int i = 1; i<=n; i++) scanf("%d",&a[i]);
		for(int i = 1; i<=m; i++) scanf("%d",&b[i]);
		for(int i = 1; i+(m-1)*p<=n; i++) {
			flag = 1;
			for(int j = i; j<=i+(m-1)*p; j+=p) {
				if(a[j] != b[(j-i)/p+1]) {
					flag=0;break;	
				}
			}
			if(flag) ans++;
		}
		printf("Case #%d: %d\n",++iCase,ans);
	}
	return 0 ;
}