Description

你工作以后, KPI 就是你的全部了. 我开发了一个服务,取得了很大的知名度。数十亿的请求被推到一个大管道后同时服务从管头拉取请求。让我们来定义每个请求都有一个重要值。我的KPI是由当前管道内请求的重要值的中间值来计算。现在给你服务记录,有时我想知道当前管道内请求的重要值得中间值。
 

Input

有大约100组数据。 

每组数据第一行有一个$n (1 \leq n \leq 10000)$,代表服务记录数。 

接下来有n行,每一行有3种形式 
  "in x": 代表重要值为$x (0 \leq x \leq 10^9)$的请求被推进管道。 
  "out": 代表服务拉取了管道头部的请求。 
  "query: 代表我想知道当前管道内请求重要值的中间值. 那就是说,如果当前管道内有m条请求, 我想知道,升序排序后第$floor(m/2)+1_{th}$ 条请求的重要值. 

为了让题目简单,所有的x都不同,并且如果管道内没有值,就不会有"out"和"query"操作。 
 

Output

对于每组数据,先输出一行 

Case #i: 
然后每一次"query",输出当前管道内重要值的中间值。 
 

Sample Input

6 in 874 query out in 24622 in 12194 query
 

Sample Output

Case #1: 874 24622

模板 照着改不对居然没发现是(q.size())/2+1)的问题

#include<iostream>
#include<cmath>
#include<cstring>
#include<ctime>
#include<cstdlib>
#include<cstdio>
#include<queue>
using namespace std;

struct Treap
{
    int size;
    int key,fix;
    Treap *ch[2];
    Treap(int key)
    {
        size=1;
        fix=rand();
        this->key=key;
        ch[0]=ch[1]=NULL;
    }
    int compare(int x) const
    {
        if(x==key) return -1;
        return x<key? 0:1;
    }
    void Maintain()
    {
        size=1;
        if(ch[0]!=NULL) size+=ch[0]->size;
        if(ch[1]!=NULL) size+=ch[1]->size;
    }
};

void Rotate(Treap* &t,int d)
{
    Treap *k=t->ch[d^1];
    t->ch[d^1]=k->ch[d];
    k->ch[d]=t;
    t->Maintain();  //必须先维护t,再维护k,因为此时t是k的子节点
    k->Maintain();
    t=k;
}

void Insert(Treap* &t,int x)
{
    if(t==NULL)
        t=new Treap(x);
    else
    {
        int d=t->compare(x);   //如果值相等的元素只插入一个
        //int d=x < t->key ? 0:1;  //如果值相等的元素都插入
        Insert(t->ch[d],x);
        if(t->ch[d]->fix > t->fix)
            Rotate(t,d^1);
    }
    t->Maintain();
}

//一般来说,在调用删除函数之前要先用Find()函数判断该元素是否存在
void Delete(Treap* &t,int x)
{
    int d=t->compare(x);
    if(d==-1)
    {
        Treap *tmp=t;
        if(t->ch[0]==NULL)
        {
            t=t->ch[1];
            delete tmp;
            tmp=NULL;
        }
        else if(t->ch[1]==NULL)
        {
            t=t->ch[0];
            delete tmp;
            tmp=NULL;
        }
        else
        {
            int k=t->ch[0]->fix > t->ch[1]->fix ? 1:0;
            Rotate(t,k);
            Delete(t->ch[k],x);
        }
    }
    else Delete(t->ch[d],x);
    if(t!=NULL) t->Maintain();
}

bool Find(Treap *t,int x)
{
    while(t!=NULL)
    {
        int d=t->compare(x);
        if(d==-1) return true;
        t=t->ch[d];
    }
    return false;
}

int Kth(Treap *t,int k)
{
    if(t==NULL||k<=0||k>t->size)
        return -1;
    if(t->ch[0]==NULL&&k==1)
        return t->key;
    if(t->ch[0]==NULL)
        return Kth(t->ch[1],k-1);
    if(t->ch[0]->size>=k)
        return Kth(t->ch[0],k);
    if(t->ch[0]->size+1==k)
        return t->key;
    return Kth(t->ch[1],k-1-t->ch[0]->size);
}

int Rank(Treap *t,int x)
{
    int r;
    if(t->ch[0]==NULL) r=0;
    else  r=t->ch[0]->size;
    if(x==t->key) return r+1;
    if(x<t->key)
        return Rank(t->ch[0],x);
    return r+1+Rank(t->ch[1],x);
}

void DeleteTreap(Treap* &t)
{
    if(t==NULL) return;
    if(t->ch[0]!=NULL) DeleteTreap(t->ch[0]);
    if(t->ch[1]!=NULL) DeleteTreap(t->ch[1]);
    delete t;
    t=NULL;
}

void Print(Treap *t)
{
    if(t==NULL) return;
    Print(t->ch[0]);
    cout<<t->key<<endl;
    Print(t->ch[1]);
}

int val[1000005];

int main()
{
   // freopen("cin.txt","r",stdin);
    int n,x,cas=1;
    char op[10];
    while(~scanf("%d",&n))
    {
        printf("Case #%d:\n",cas++);
        queue<int>q;
        Treap *root=NULL;
        for(int i=0;i<n;i++)
        {
            scanf("%s",op);
            if(op[0]=='i')
            {
                int x;
                scanf("%d",&x);
                q.push(x);
                Insert(root,x);
            }
            else if(op[0]=='q')
            {
                //printf("size = %d q.size()=%d \n",root->size,q.size());
                printf("%d\n",Kth(root,(q.size())/2+1));
            }
            else
            {
                int t=q.front();q.pop();
                //int k=treap.find(treap.root,t);
              //  printf("size = %d\n",root->size);
                Delete(root,t);
                //printf("size = %d\n",root->size);
            }
        }
        /*for(int i=1; i<=n; i++)
            scanf("%d",&val[i]);
        int index=1;

        for(int i=1; i<=m; i++)
        {
            scanf("%d",&x);
            for(int j=index; j<=x; j++)
                Insert(root,val[j]);
            index=x+1;
            printf("%d\n",Kth(root,i));
        }*/
        //DeleteTreap(root);
    }
    return 0;
}