A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35406    Accepted Submission(s): 14406


 

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

 

 

Input

The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

 

Output

For each test case,print the sum of A and B in hexadecimal in one line.

 

Sample Input

+A -A

+1A 12

1A -9

-1A -12

1A -AA

Sample Output

0

2C

11

-2C

-90

题意:

      计算16进制之间的加法。

思路:

      直接用16进制进行计算。

格式字符 格式字符意义 
d   以十进制形式输出带符号整数(正数不输出符号) 
o 以八进制形式输出无符号整数(不输出前缀O) 
x   以十六进制形式输出无符号整数(不输出前缀OX) 
u   以十进制形式输出无符号整数 
f   以小数形式输出单、双精度实数 
e   以指数形式输出单、双精度实数 
g   以%f%e中较短的输出宽度输出单、双精度实数 
c   输出单个字符 
s   输出字符串

代码:

#include<stdio.h>
int main()
{
	long long a,b,sum;
	while(scanf("%llx%llx",&a,&b)!=EOF)
	{
		sum=a+b;
		if(sum>=0)
			printf("%llX\n",sum);
		else
			printf("-%llX\n",-sum);
	}
	return 0;
}