Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
题意:最长连续子序列和,经典题型就是需要记录一下起始和终止的节点
动态规划的状态转移方程是
if(f[i-1]<0)f[i]=a[i];
else f[i]=f[i-1]+a[i];
意思就是如果前面的序列和小于零,就重新起个头,最后判断一下每一个f[i]找出最大的序列和
#include <iostream>
#include <stdio.h>
#include <cstring>
#define maxn 100000+5
using namespace std;
int a[maxn],f[maxn];
int main()
{
int t,kase=0;
scanf("%d",&t);
while(t--){
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&f[i]);
int start=0,fl=0,fr=0;
int maxsum=f[0];
for(int i=1;i<n;i++){
if(f[i-1]<0)start=i;
else f[i]=f[i-1]+f[i];
if(f[i]>maxsum){
maxsum=f[i];
fl=start;
fr=i;
}
}
if (kase)
printf("\n");
printf("Case %d:\n", ++kase);
printf("%d %d %d\n", maxsum, fl+1, fr+1);
}
return 0;
}