题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2899
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

Problem solving report:

Description: 输入一个Y,求方程的最小解。
Problem solving: 首先x>=0可知,函数在定义域上为单峰凹函数,对函数求导,当导函数为0时取得极值,最小值必在极值处。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
const double eps = 1e-8;
double y;
double cal(double x) {
    return 42 * pow(x, 6) + 48 * pow(x, 5) + 21 * pow(x, 2) + 10 * x - y;
}
double ask(double x) {
    return 6 * pow(x, 7) + 8 * pow(x, 6) + 7 * pow(x, 3) + 5 * pow(x, 2) - y * x;
}
int main() {
    int t;
    scanf("%d", &t);
    while (t--) {
        scanf("%lf", &y);
        double l = 0, r = 100;
        while (r - l > eps) {
            double mid = (l + r) / 2;
            if (cal(mid) < eps)
                l = mid + eps;
            else r = mid - eps;
        }
        printf("%.4f\n", ask(l));
    }
    return 0;
}