<center>
提交: 10 解决: 7
</center>
问题 B: Friendship of Mouse
时间限制: 1 Sec 内存限制: 64 MB提交: 10 解决: 7
</center>
题目描述
Today in KBW, N mice from different cities are standing in a line. Each city is represented by a lowercase letter. The distance between adjacent mice (e.g. the 1 st and the 2 nd mouse, the N−1 th and the N th mouse, etc) are exactly 1. Two mice are friends if they come from the same city.
The closest friends are a pair of friends with the minimum distance. Help us find that distance.
The closest friends are a pair of friends with the minimum distance. Help us find that distance.
输入
First line contains an integer T, which indicates the number of test cases.
Every test case only contains a string with length N, and the i th character of the string indicates the city of i th mice.
⋅ 1≤T≤50.
⋅ for 80% data, 1≤N≤100.
⋅ for 100% data, 1≤N≤1000.
⋅ the string only contains lowercase letters.
Every test case only contains a string with length N, and the i th character of the string indicates the city of i th mice.
⋅ 1≤T≤50.
⋅ for 80% data, 1≤N≤100.
⋅ for 100% data, 1≤N≤1000.
⋅ the string only contains lowercase letters.
输出
For every test case, you should output "Case #x: y", where x indicates the case number and counts from 1 and y is the result. If there are no mice in same city, output −1 instead.
样例输入
2
abcecba
abc
样例输出
Case #1: 2
Case #2: -1
思路:
2015 ICPC 上海站F题,很水的一道打卡题,怎么做都行,N^2暴力都无所谓...
代码:
#include<iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 1005
#define inf 99999
using namespace std;
char str[maxn];
int main ()
{
//freopen("in.txt","r",stdin);
int n;
scanf("%d", &n);
for (int i = 1; i <= n; i++)
{
scanf("%s", str);
int len = strlen(str);
int ans = 99999;
for (int q = 0; q < len; q++)
for (int w = q + 1; w < len; w++)
{
if (str[q] == str[w])
ans = min(ans, w - q);
}
if (ans == inf) ans = -1;
printf("Case #%d: %d\n", i, ans);
}
return 0;
}