题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1222
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

There is a hill with n holes around. The holes are signed from 0 to n-1.

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

Sample Input

2
1 2
2 2

Sample Output

NO
YES

Problem solving report:

Description: n个洞,编号0~n-1围成一个环,狼会从0开始隔m进入隔m进入,判断是否存在安全洞。
Problem solving: 找规律可得m与n互质的话不存在安全洞。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
int main() {
    int t, n, m;
    scanf("%d", &t);
    while (t--) {
        scanf("%d%d", &n, &m);
        if (__gcd(n, m) != 1)
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}