Problem Description
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

#include <iostream>
#include <iostream>
using namespace std;
int arr[1000001] = {0};
int main(int argc, char const *argv[])
{
    int n = 0;
    cin >> n;
    for (int k = 1; k <= n; ++k)
    {
        int t = 0;
        cin >> t;
        int i = 0, j = 0;
        int res = INT32_MIN;
        int sum = 0;
        int f = 1;
        for (int p = 1; p <= t; ++p)
        {
            cin >> arr[p];
            if (sum >= 0)
            {
                sum += arr[p];
            }
            else
            {
                sum = arr[p];
                f = p;
            }
            if (sum > res)
            {
                res = sum;
                i = f;
                j = p;
            }
        }
        cout << "Case " << k << ":" << endl;
        cout << res << " " << i << " " << j << endl;
        if (k != n)
            cout << endl;
    }
    return 0;
}