Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

题意:

     这人背着包捡骨头,问他能捡到最大是多大价值的骨头。(我也不知道这人啥口味,捡点啥不好。。。)

思路:

     就是差不多01背包模板题了。

     dp[i][j]表示到第i个骨头面前容量为 j 的的背包所能当下骨头最大价值。

代码:

#include<stdio.h>
int dp[1010][1010];
int max(int x,int y)
{
	if(x>=y)
		return x;
	else
		return y;
}
int main()
{
	int t,n,m,i,j;
	int value[1010],v[1010];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			scanf("%d",&value[i]);
		for(i=1;i<=n;i++)
			scanf("%d",&v[i]);
		for(i=0;i<m;i++)
			dp[1][i]=0;
		for(i=1;i<=n;i++)
			for(j=0;j<=m;j++)
			{
				if(j<v[i])
					dp[i][j]=dp[i-1][j];
				else
					dp[i][j]=max(dp[i-1][j],dp[i-1][j-v[i]]+value[i]);
			}
		printf("%d\n",dp[n][m]);
	}
	return 0;
}