题目链接:http://poj.org/problem?id=2387
Time Limit: 1000MS Memory Limit: 65536K

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 
There are five landmarks. 

OUTPUT DETAILS: 
Bessie can get home by following trails 4, 3, 2, and 1.

Problem solving report:

Description: 求n到1的最短距离。
Problem solving: 直接上最短路,注意重边的问题。

Accepted Code:

/* 
 * @Author: lzyws739307453 
 * @Language: C++ 
 */
#include <cmath>
#include <queue>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 1005;
const int inf = 0x3f3f3f3f;
bool vis[MAXN];
int dis[MAXN], f[MAXN], cnt;
struct edga {
    int s, t;
    edga() {}
    edga(int s, int t) : s(s), t(t) {}
    bool operator < (const edga &s) const {
        return s.t < t;
    }
};
struct edge {
    int u, v, w;
    edge() {}
    edge(int u_, int v_ , int w_) : u(u_), v(v_), w(w_) {}
}e[MAXN << 2];
inline void Add(int u, int v, int w) {
    e[++cnt] = edge(f[u], v, w);
    f[u] = cnt;
}
inline void init() {
    cnt = 0;
    memset(f, -1, sizeof(f));
    memset(dis, 0x3f, sizeof(dis));
    memset(vis, false, sizeof(vis));
}
inline int Dijkstra(int s, int n) {
    priority_queue <edga> Q;
    dis[s] = 0;
    Q.push(edga(s, dis[s]));
    while (!Q.empty()) {
        edga u = Q.top();
        Q.pop();
        if (vis[u.s])
            continue;
        vis[u.s] = true;
        for (int i = f[u.s]; ~i; i = e[i].u) {
            int v = e[i].v;
            if (dis[v] > u.t + e[i].w) {
                dis[v] = u.t + e[i].w;
                Q.push(edga(v, dis[v]));
            }
        }
    }
    return dis[n];
}
int main() {
    int t, n, m, p, u, v, w;
    while (~scanf("%d%d", &m, &n)) {
        init();
        for (int i = 0; i < m; i++) {
            scanf("%d%d%d", &u, &v, &w);
            Add(u, v, w);
            Add(v, u, w);
        }
        printf("%d\n", Dijkstra(1, n));
    }
    return 0;
}