Frogger

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意描述:

给出n 块石头及其坐标,求出1号石头到2号石头所经过路径中最大值最小的数(使青蛙不用一次跳太远的距离)

解题思路:

输入数据求出各个石头间的距离,存入二维数组中,将迪杰斯特拉算法中求路径的最短,判断dis[v]>dis[u]+map[u][v];更改为dis[v]>max(dis[u],map[u][p]);

#include<stdio.h>
#include<string.h>
#include<math.h>
# define inf 99999999
double dis[210],map[210][210];//dis数组存储的为1到各个石头块路径中的最大值,更新使最大值最小 
int book[210],x[210],y[210];
double max(double a,double b)
{
	if(a>=b)
		return a;
	else
		return b;
}
int main()
{
	int n,i,j,u,v,min,t;
	t=0;
	while(scanf("%d",&n))
	{
		if(n==0)
			break;
		t++;
		for(i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				map[i][j]=0;
		//求出各个石头间的距离,存入地图	
		for(i=1;i<n;i++)
			for(j=i+1;j<=n;j++)
			{
				map[i][j]=(double)sqrt((fabs(x[i]-x[j])*fabs(x[i]-x[j])+fabs(y[i]-y[j])*fabs(y[i]-y[j]))*1.0);
				map[j][i]=map[i][j];
			}
		for(i=1;i<=n;i++)
			dis[i]=map[1][i];
		memset(book,0,sizeof(book));
		book[1]=1;
		for(i=1;i<n;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(book[j]==0&&min>dis[j])
				{
					min=dis[j];
					u=j;
				}
			}
			book[u]=1;
			for(v=1;v<=n;v++)
			{
				if(dis[v]>max(dis[u],map[u][v]))//找到路径中的最大值都小,更改dis数组值 
					dis[v]=max(dis[u],map[u][v]);
			}
		}
		printf("Scenario #%d\n",t);
		printf("Frog Distance = %.3f\n\n",dis[2]);
	}
	return 0;
}