Frogger
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4
3
17 4
19 4
18 5
0
Sample Output
Scenario #1
Frog Distance = 5.000
Scenario #2
Frog Distance = 1.414
题意:就是让你求从1到2的路径所经过的最大权值的最小值
分析:用Dijkstra的变形,每个路径的长度是这条路径所经过的最大权值
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
int x,y;
}p[205];
double G[205][205];//邻接矩阵
double dis[205];
bool vis[205];
int n;
const double Inf=1e16;
double f(node a,node b){//求两点间的距离
return sqrt((b.x-a.x)*(b.x-a.x)+ (b.y-a.y)*(b.y-a.y));
}
void dj(){
for(int i=1;i<=n;i++){
dis[i]=G[1][i];
vis[i]=false;
}
vis[1]=true;
for(int k=0;k<n;k++){
int mint=Inf,u=-1;
for(int i=1;i<=n;i++){
if(!vis[i]&&dis[i]<mint){
mint=dis[i];
u=i;
}
}
vis[u]=true;
for(int i=1;i<=n;i++){
if(!vis[i]&&dis[i]>max(G[u][i],dis[u])){
dis[i]=max(G[u][i],dis[u]);
}
}
}
printf("Frog Distance = %.3f\n\n",dis[2]);//注意输出,还有一行空行
}
int main(){
int x,y,t=0;
while(scanf("%d",&n)&&n){
t++;
for(int i=1;i<=n;i++)
scanf("%d%d",&p[i].x,&p[i].y);
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
if(i==j) G[i][j]=0;
else G[i][j]=f(p[i],p[j]);
}
}
printf("Scenario #%d\n",t);
dj();
}
return 0;
}