<center style="color&#58;rgba&#40;0&#44;0&#44;0&#44;&#46;87&#41;&#59;font&#45;family&#58;Lato&#44; &#39;Helvetica Neue&#39;&#44; Arial&#44; Helvetica&#44; sans&#45;serif&#59;font&#45;size&#58;14px&#59;">

问题 : 看电视

时间限制: 1 Sec   内存限制: 32 MB
</center>

题目描述

暑假到了,小明终于可以开心的看电视了。但是小明喜欢的节目太多了,他希望尽量多的看到完整的节目。
现在他把他喜欢的电视节目的转播时间表给你,你能帮他合理安排吗?

输入

输入包含多组测试数据。每组输入的第一行是一个整数n(n<=100),表示小明喜欢的节目的总数。
接下来n行,每行输入两个整数si和ei(1<=i<=n),表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。
当n=0时,输入结束。

输出

对于每组输入,输出能完整看到的电视节目的个数。

样例输入

12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0

样例输出

5

解题思路

这道题是一道简单的贪心问题,其实就是让你找互不相交的最大区间数。
#include <stdio.h>
#include <algorithm>
using namespace std;
struct node{
    int left, right;
} arr[102];
int cmp(node x, node y)
{
    return x.right < y.right;
}
int main()
{
    int t, n, x, y, r, temp, count;
    while (scanf("%d", &n), n)
    {
        for (int i = 0; i < n; i++)
            scanf("%d%d", &arr[i].left, &arr[i].right);
        sort(arr, arr + n, cmp);
        temp = arr[0].right;
        count = 1;
        for (int i = 1; i < n; i++)
        {
            if (temp <= arr[i].left)
            {
                temp = arr[i].right;
                count++;
            }
        }
        printf("%d\n", count);
    }
    return 0;
}