题干:

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

解题报告:

     差分约束系统+spfa。这时候就不能用Dijkstra啦,因为有负权了。当成个模板记住也好啊。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int INF = 0x3f3f3f3f;
int head[10000 + 5];
bool vis[10000 + 5];
int ci[10000 + 5],dis[10000 + 5];
int cnt,n;
struct Edge{
	int to;
	int w;
	int ne;
}e[20000 + 5];
void add(int u,int v,int w) {
	e[cnt].to = v;
	e[cnt].w = w;
	e[cnt].ne = head[u];
	head[u] = cnt++;
}
int spfa(int st) {
	dis[st] = 0;vis[st] = 1;
	queue<int > q;
	q.push(st);
	while(!q.empty()) {
		int cur = q.front();
		q.pop();
		vis[cur] = 0;
		for(int i = head[cur]; i!=-1; i = e[i].ne) {
			if(dis[e[i].to]>dis[cur]+e[i].w ) {
				dis[e[i].to]=dis[cur]+e[i].w ;
				if(vis[e[i].to] == 0) {
					vis[e[i].to] = 1;
					q.push(e[i].to);
					ci[e[i].to]++;
					if(ci[e[i].to]>=n) return -1;
				} 
			}
		}
	}
	if(dis[n] == INF) return -2;
	else return dis[n];
}
//void init() {
//	cnt = 0;
//	memset()
//}
int main()
{
	int a,b,w;
	int ml,md;
	while(~scanf("%d%d%d",&n,&ml,&md)) {
		cnt = 0;
		memset(head, -1, sizeof(head));
		memset(ci,0,sizeof(ci));
		memset(vis,0,sizeof(vis));
		memset(dis,INF,sizeof(dis));
		while(ml--) {
			scanf("%d%d%d",&a,&b,&w);
			if(a>b)swap(a,b);
			add(a,b,w);
		}
		while(md--) {
			scanf("%d%d%d",&a,&b,&w);
			if(a<b) swap(a,b);
			add(a,b,-w);
		}
		printf("%d\n",spfa(1));
	}
	
	return 0 ;
}