Networking
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 9388 | Accepted: 5142 |
Description
You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input
The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.
Output
For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input
1 0 2 3 1 2 37 2 1 17 1 2 68 3 7 1 2 19 2 3 11 3 1 7 1 3 5 2 3 89 3 1 91 1 2 32 5 7 1 2 5 2 3 7 2 4 8 4 5 11 3 5 10 1 5 6 4 2 12 0
Sample Output
0 17 16 26
Source
题意:
题意就是给你n个点,m条边,让你求组成通路的最小生成树。
套模板。
但是这个题让我发现了原来的模板是有问题的。《啊哈!算法》一书在其讲krusakal求最小生成树一节中的代码是有问题的,问题就出现在它手写的quicksort上面。
思路:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<cstdlib>
using namespace std;
struct edge
{
int u;
int v;
int w;
}e[10000];
int f[150]={0};
int sum=0,countt=0,n;
void init()
{
for(int i=1;i<=n;i++)
{
f[i]=i;
}
countt=0;
sum=0;
}
int partition(int left,int right)
{
int i,j;
struct edge t,key;
key=e[left];
i=left;
j=right;
while(i<j)
{
while(e[j].w>=key.w&&i<j)j--;
if(i<j)
{
e[i]=e[j];
i++;
}
while(e[i].w<key.w&&i<j)i++;
if(i<j)
{
e[j]=e[i];
j--;
}
}
e[i]=key;
return i;
}
void quicksort(int left,int right)//原书这里写的出了些mistakes
{
if(left<right)
{
int pos=partition(left,right);
quicksort(left,pos-1);
quicksort(pos+1,right);
}
return ;
}
int find(int v)
{
if(f[v]==v)return v;
else
{
f[v]=find(f[v]);
return f[v];
}
}
int merge(int v,int u)
{
int t1,t2;
t1=find(v);
t2=find(u);
if(t1!=t2)
{
f[t2]=t1;
return 1;
}
return 0;
}
int main()
{
int m;
while(scanf("%d%d",&n,&m)!=EOF&&n)
{
init();
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
}
quicksort(1,m);
for(int i=1;i<=m;i++)
{
if(merge(e[i].u,e[i].v))
{
countt++;
sum+=e[i].w;
}
if(countt==n-1)
{
break;
}
}
printf("%d\n",sum);
// for(int i=1;i<=m;i++)cout<<e[i].u<<" "<<e[i].v<<" "<<e[i].w<<endl;
}
return 0;
}