题干:
Bulls are so much better at math than the cows. They can multiply huge integers together and get perfectly precise answers ... or so they say. Farmer John wonders if their answers are correct. Help him check the bulls' answers. Read in two positive integers (no more than 40 digits each) and compute their product. Output it as a normal number (with no extra leading zeros).
FJ asks that you do this yourself; don't use a special library function for the multiplication.
Input
* Lines 1..2: Each line contains a single decimal number.
Output
* Line 1: The exact product of the two input lines
Sample Input
11111111111111
1111111111
Sample Output
12345679011110987654321
解题报告:
水题模拟。
ac代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAX =1000 + 5 ;
char s1[MAX],s2[MAX];
int a[MAX],b[MAX],ans[MAX];
int len1,len2;
int p,c;//p代表当前位置,c代表进位
int main()
{
// freopen("in.txt","r",stdin);
scanf("%s",s1);
scanf("%s",s2);
len1=strlen(s1);len2=strlen(s2);
//
for(int i = 1; i<=len1; i++) {
a[len1-(i-1)]=s1[i-1]-'0';
}
for(int i = 1; i<=len2; i++) {
b[len2-(i-1)]=s2[i-1]-'0';
}
// for(int i = len1; i>=1; i--) printf("%d",a[i]);
// printf("\n");
// for(int i = len2; i>=1; i--) printf("%d",b[i]);
// printf("\n");
for(int i = 1; i<=len2; i++) {
for(int j = 1; j<=len1; j++) {
ans[i+j-1] += b[i]*a[j];
}
}
for(int i = 1; i<=len1+len2; i++) {
p=i;
if(ans[i]<=9) continue;
c=ans[i]/10;
while(c>0) {
ans[++p] += c;
ans[p-1]=ans[p-1]%10;
c= ans[p]/10;
}
//或者用下面的代码:
// while(ans[i]>9) {
// ans[i]-=10;
// ans[i+1]++;
// }
}
// printf("p = %d\n",p);
for(int i = len1+len2; i>=1; i--) {
if(ans[i]!=0) {
p=i;break;
}
}
for(int i = p; i>=1; i--) {
printf("%d",ans[i]);
}
printf("\n");
return 0 ;
}
//bzoj 1754 [Usaco2005 qua]Bull Math
//11111111111111
//1111111111
错误代码:(有空看看哪里有问题)
Bull Math
)
#include<bits/stdc++.h>
using namespace std;
const int MAX =1000 + 5 ;
char s1[MAX],s2[MAX];
int a[MAX],b[MAX],ans[MAX];
int len1,len2;
int p,c;//p代表当前位置,c代表进位
int main()
{
freopen("in.txt","r",stdin);
scanf("%s",s1);
scanf("%s",s2);
len1=strlen(s1);len2=strlen(s2);
//
for(int i = 1; i<=len1; i++) {
a[len1-(i-1)]=s1[i-1]-'0';
}
for(int i = 1; i<=len2; i++) {
b[len2-(i-1)]=s2[i-1]-'0';
}
// for(int i = len1; i>=1; i--) printf("%d",a[i]);
// printf("\n");
// for(int i = len2; i>=1; i--) printf("%d",b[i]);
// printf("\n");
for(int i = 1; i<=len2; i++) {
p=i;
c=0;
for(int j = 1; j<=len1; j++) {
ans[p]+=b[i]*a[j];
c=ans[p]/10;
ans[p]%=10;
while(c>0) {
ans[++p] += c%10;//这里是+=!!
c/=10;
}
}
for(int i = p; i>=1; i--) {
printf("%d",ans[i]);
}
printf("\n");
}
for(int i = p; i>=1; i--) {
printf("%d",ans[i]);
}
printf("\n");
return 0 ;
}
//bzoj 1754 [Usaco2005 qua]Bull Math
//11111111111111
//1111111111
总结:
你在搞笑吗这么简单的模拟你搞了一个小时。。。。逻辑关系能不能理清楚了再敲啊。。。
// printf("p = %d\n",p);