Farm Irrigation

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.
 

                    Figure 1

 

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like
 

        Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2

DK

HF

3 3

ADC

FJK

IHE

-1 -1

Sample Output

2

3

题意描述:
不同的土地埋藏得管道不同,问需要几个灌溉井可以使整大块的田地都灌溉上,管道相连的土地只需要一个灌溉进就行了。

解题思路:

将每块土地四周有管道口的方向标记为1,无管道口的方向标记为0。运用深搜进行查找,对于一块土地,在它有管道口的方向有土地刚好也有管道口可以接上则两块土地就可看成一个土地,查找过得土地进行标记。

#include<stdio.h>
#include<string.h>
int a[600][600],book[600][600];
int n,m;
int next[11][4]={//左,上,右,下 
                    1,1,0,0,//A
	            0,1,1,0,//B
		    1,0,0,1,//C
		    0,0,1,1,//D
		    0,1,0,1,//E
		    1,0,1,0,//F
		    1,1,1,0,//G
		    1,1,0,1,//H
		    1,0,1,1,//I
		    0,1,1,1,//J
		    1,1,1,1//K
		  };
void dfs(int x,int y);
int main()
{
	int i,j,num;
	char s[600][600];
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n<0&&m<0)
			break;
		memset(book,0,sizeof(book));
		for(i=0;i<n;i++)
				scanf("%s",s[i]);
		
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
				a[i][j]=s[i][j]-'A';
			
		num=0;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				if(book[i][j]==0)
				{
					book[i][j]=1;
					num++;
					dfs(i,j);
				}
			}
		printf("%d\n",num);
	}
	return 0;
}
void dfs(int x,int y)
{
	//判断下一块土地符合,标记继续搜索 
	if(y-1>=0&&next[a[x][y-1]][2]==1&&book[x][y-1]==0&&next[a[x][y]][0]==1)
	{
		book[x][y-1]=1;
		dfs(x,y-1);
	}
	if(x-1>=0&&next[a[x-1][y]][3]==1&&book[x-1][y]==0&&next[a[x][y]][1]==1)
	{
		book[x-1][y]=1;
		dfs(x-1,y);
	}
	if(y+1<m&&next[a[x][y+1]][0]==1&&book[x][y+1]==0&&next[a[x][y]][2]==1)
	{
		book[x][y+1]=1;
		dfs(x,y+1);
	}
	if(x+1<n&&next[a[x+1][y]][1]==1&&book[x+1][y]==0&&next[a[x][y]][3]==1)
	{
		book[x+1][y]=1;
		dfs(x+1,y);
	}
	return;
}