There are <var>n</var> courses in the course selection system of Marjar University. The <var>i</var>-th course is described by two values: happiness <var>H</var><var>i</var> and credit <var>C</var><var>i</var>. If a student selects <var>m</var> courses <var>x</var>1, <var>x</var>2, ..., <var>x</var><var>m</var>, then his comfort level of the semester can be defined as follows:
Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?
Input
There are multiple test cases. The first line of input contains an integer <var>T</var>, indicating the number of test cases. For each test case:
The first line contains a integer <var>n</var> (1 ≤ <var>n</var> ≤ 500) -- the number of cources.
Each of the next <var>n</var> lines contains two integers <var>H</var><var>i</var> and <var>C</var><var>i</var> (1 ≤ <var>H</var><var>i</var> ≤ 10000, 1 ≤ <var>C</var><var>i</var> ≤ 100).
It is guaranteed that the sum of all <var>n</var> does not exceed 5000.
We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.
Output
For each case, you should output one integer denoting the maximum comfort.
Sample Input
2 3 10 1 5 1 2 10 2 1 10 2 10
Sample Output
191 0
Hint
For the first case, Edward should select the first and second courses.
For the second case, Edward should select no courses.
Author: WANG, Yucheng
Source: The 17th Zhejiang University Programming Contest Sponsored by TuSimple
题意:已知每个物品的幸福值H[i]和信用值C[i],要求实现输出其最大值
思路:
幸福值→价值 , 信用值→重量。 假若背包容量给定,那么通过01背包DP可以求出在给定容积下可获得的最大价值。
观察数据,发现容量不超过50000,暴力枚举容积,可求得最大的价值。并且该方程对称轴在x轴左侧,开口朝上。
那么当容积确定后,幸福值越大,该方程的值越大。复杂度为O(T*n*50000)
AC代码:
#include <stdio.h>
#include <string.h>
using namespace std;
typedef long long ll;
const int MAX_N=1e6+3;
const int MOD=1e9+7;
int dp[MAX_N];
int w[MAX_N],v[MAX_N];
int n,m;
ll max(ll a,ll b){
return a>b ? a :b;
}
int main(void){
int T;
scanf("%d",&T);
while(T--){
scanf("%d",&n);
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;++i) scanf("%d%d",&v[i],&w[i]);
///求出每个背包容量对应能获得的最大价值,枚举容积的原因在于背包容量小
for(int i=1;i<=n;i++)
for(int j=50000;j>=w[i];j--) dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
ll ans=0;
for(int i=1;i<=50000;i++) ans=max(ans,1LL*dp[i]*dp[i]-1LL*dp[i]*i-1LL*i*i);
printf("%lld\n",ans);
}
}