题干:

 

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 


We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

解题报告:

跟这题一样【POJ - 2318】TOYS,只是输出的格式不一样 。那个题是要输出第i个盒子中有多少玩具,这个是要输出共装有i个玩具的盒子有多少个。

AC代码:

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
int n,m,x1,x2,y1,y2;//n个板子,m个玩具,左上角,右下角。 
int num[2005];
struct Edge {
	int x1,y1;//上 
	int x2,y2;//下 
} e[5005];
struct Node {
	int x,y;
} node[5005];
int ans[5005];
int cal(int tar,int line) {
	return (node[tar].x - e[line].x2)*(e[line].y1-e[line].y2) - (e[line].x1 - e[line].x2)*(node[tar].y - e[line].y2);
} 
bool cmp(Edge a,Edge b) {
	return a.x1 < b.x1;
}
int main()
{
	while(cin>>n) {
		memset(num,0,sizeof num);
		if(n == 0) break;
		cin>>m>>x1>>y1>>x2>>y2;
		memset(ans,0,sizeof ans);
		for(int i = 1; i<=n; i++) {
			scanf("%d%d",&e[i].x1,&e[i].x2);
			e[i].y1 = y1;
			e[i].y2 = y2;
		}
		sort(e+1,e+n+1,cmp);
		for(int i = 1; i<=m; i++) {
			scanf("%d%d",&node[i].x,&node[i].y);
		}
		//process each 
		for(int i = 1; i<=m; i++) {
			int l = 1,r = n;
			int mid = (l+r)/2;
			while(l<r) {
				mid = (l+r)/2;
				if(cal(i,mid) > 0) l=mid+1;
				else r=mid; 
			}
			if(l == n) {
				if(cal(i,l) < 0) ans[l]++;
				else ans[l+1]++;				
			}
			else ans[l]++;
		}
		for(int i = 1; i<=n+1; i++) {
			num[ans[i]]++;
		}
		puts("Box");
		for(int i = 1; i<=m; i++) {
			if(num[i]!=0) printf("%d: %d\n",i,num[i]);
		}
	}
	return 0 ;
 }