Problem A : STEED Cards


<a type="button" class="btn btn-default" href="/solution/submit.html?problemId=5284">Submit</a> (Out of Contest)
<center> Time Limit: 1 s </center>

Description

Corn does not participate the STEED contest, but he is interested in the word "STEED". So, Corn writes all permutations of the word "STEED" on different cards and gets 60 cards finally.

Corn sorts these cards in lexicographical order, and marks them from 1 to 60.

Now, Corn gives you a integer N (1 ≤ N ≤ 60), could you tell him the word on the Nth card?

 

Input

There are multiple test cases (no more than 60).
For each test case, there is one integer N (1 ≤ N ≤ 60) in a line.

 

Output

For each test case, you should output one line with the word on the Nth card.

 

Sample Input

1
2
3
4
47
48
49

 

Sample Output

DEEST
DEETS
DESET
DESTE
STEDE
STEED
TDEES

 


Author: Corn


#include<iostream>
#include<cstdio>
using namespace std;
 
char s[60][6]={"DEEST","DEETS","DESET","DESTE","DETES",
"DETSE","DSEET","DSETE","DSTEE","DTEES","DTESE","DTSEE","EDEST",
"EDETS","EDSET","EDSTE","EDTES","EDTSE","EEDST","EEDTS","EESDT","EESTD",
"EETDS","EETSD","ESDET","ESDTE","ESEDT","ESETD","ESTDE","ESTED","ETDES","ETDSE",
"ETEDS","ETESD","ETSDE","ETSED","SDEET","SDETE","SDTEE","SEDET","SEDTE",
"SEEDT","SEETD","SETDE","SETED","STDEE","STEDE","STEED","TDEES","TDESE",
"TDSEE","TEDES","TEDSE","TEEDS","TEESD","TESDE","TESED","TSDEE","TSEDE","TSEED"
};
int main()
{
    int n;
    while(cin>>n){
        cout<<s[n-1]<<endl; 
    }
    return 0;
}