Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 26943   Accepted: 9873

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

题意:有一个矩阵,里面所有数字都是0,有两种操作,c操作,把一个矩形里的数字都取非,q操作,展示某个点的值。

#include <iostream>
#include<string.h>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstdlib>
using namespace std;
const int Max = 1128;
int data[Max][Max],n,k;
int lowbit(int x)//求出该移动的距离
{
    return x&-x;
}
void add(int x,int y,int w)//维护树状数组更新,从前往后;
{
    for(int i=x;i<=n;i+=lowbit(i))
    {
        for(int j=y;j<=n;j+=lowbit(j))
        {
            data[i][j]+=w;
        }
    }
}
int sum(int x,int y)
{
    int ans = 0;
    for(int i = x;i>0;i-=lowbit(i))//求出该点处更改次数,从该点向左一直到i<=0
    {
        for(int j = y;j>0;j-=lowbit(j))
        {
            ans += data[i][j];
        }
    }
    return ans;
}
int main()
{
char str[103];
int t;
cin>>t;
while(t--)
{
    cin>>n>>k;
    memset(data,0,sizeof(data));//第一组数据对,wr一般是未进行初始化,其中初始化时sizeof用数组名
    while(k--)
    {
        scanf("%s",str);//有字符数字空格输入,推荐采用字符串输入
        if(str[0]=='C')
        {
            int x1,y1,x2,y2;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);//输入数据推荐使用scanf
            add(x1,y1,1);
            add(x1,y2+1,-1);
            add(x2+1,y1,-1);
            add(x2+1,y2+1,1);//树状数组跟新左侧不变,右侧加1,即(x,y+1)
            //此处用到了容斥原理

        }
        else
        {
            int x,y;
            scanf("%d%d",&x,&y);
            cout<<sum(x,y)%2<<endl;//更改次数跟2取余即为翻转
        }
    }
    if(t)
    cout<<endl;//看准题意,两组数据之间有一组空格
}
return 0;
}




备注:基础一维http://www.hankcs.com/program/algorithm/poj-3109-inner-vertices.html

POJ 3109 Inner Vertices

本题参考博客:
http://blog.csdn.net/libin56842/article/details/46620445
http://blog.csdn.net/int64ago/article/details/7429868:搞懂树状数组
http://download.csdn.net/detail/lenleaves/4548401:论文二进制思想的应用