More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 25429    Accepted Submission(s): 9124


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 

Author
lxlcrystal@TJU
 

Source


题意:

题意就是找一个并查集中的最大森林的树木的个数。并查集。要用以前的模板。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<cstdlib>
using namespace std;

int f[10000000+5]={0},n=10000000,m,k;
int num[10000000+5]={0};

void init()
{
	for(int i=1;i<n+5;i++)
	{
		f[i]=i;	
		num[i]=1;
	}
}

int find(int v)
{
	if(f[v]==v)
		return v;
	else
	{
		f[v]=find(f[v]);
		return f[v];
	}
}

void merge(int v,int u)
{
	int t1,t2;
	t1=find(v);
	t2=find(u);
	if(t1!=t2)
	{
		f[t1]=t2;
		num[t2]+=num[t1];//计算合并后的元素的个数
	}
}


int main()
{
	while(scanf("%d",&m)!=EOF)
	{
		if(m==0) 
        {  
            printf("1\n");  
            continue;  
        }  
		init();
		int maxnum=0;
		for(int i=1;i<=m;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			merge(a,b);
			maxnum=max(maxnum,max(a,b));//找出最大的编号
		}
		int maxn=0;
		for(int i=1;i<=maxnum;i++)
		{
			if(num[i]>maxn)
			{
				maxn=num[i];
			}
		}
		printf("%d\n",maxn);		
	} 
	return 0;
}