题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2844

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Problem solving report:

Description: 给出每种硬币的价值和每种硬币的个数,求在m以内能组成多少种价值。
Problem solving: 完全背包。只不过加了个数的限制,用cnt来表示已使用的i硬币的个数,超过限制以后就停止使用这种硬币。

#include <bits/stdc++.h>
using namespace std;
int v[105], w[105], dp[100005], cnt[100005];
int main() {
    int m, n;
    while (~scanf("%d%d", &n, &m), n + m) {
        memset(dp, 0, sizeof(dp));
        for (int i = 0; i < n; i++)
            scanf("%d", v + i);
        for (int i = 0; i < n; i++)
            scanf("%d", w + i);
        dp[0] = 1;
        int ans = 0;
        for (int i = 0; i < n; i++) {
            memset(cnt, 0, sizeof(cnt));
            for (int j = v[i]; j <= m; j++) {
                if (!dp[j] && dp[j - v[i]] && cnt[j - v[i]] < w[i]) {
                    ans++;
                    dp[j] = 1;
                    cnt[j] = cnt[j - v[i]] + 1;
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}