Red and Black

 

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0

Sample Output

45

59

6

13

题意描述:
求出与’@’四个方向相邻的所有 ’ . ’ 的个数。

解题思路:

利用广搜查找所有的图,符合条件的点,总数加一;(啊哈算法模板题)

#include<stdio.h>
#include<string.h>
struct note
{
	int x;
	int y;
};
int main()
{
	struct note que[2500];
	int head,tail;
	char a[50][50];
	int book[50][50];
	int i,j,k,sum,mx,my,n,m,tx,ty,strx,stry;
	int next[4][2]={0,1,
					1,0,
					0,-1,
					-1,0};
	while(scanf("%d%d",&m,&n))
	{
		if(n==0&&m==0)
			break;
		for(i=0;i<n;i++)
			scanf("%s",a[i]);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
				if(a[i][j]=='@')
				{
					strx=i;
					stry=j;
				}
		sum=0;
		memset(book,0,sizeof(book));
		head=1;
		tail=1;
		
		que[tail].x=strx;
		que[tail].y=stry;
		tail++;
		book[strx][stry]=1;
		sum=1;
			
		while(head<tail)
		{
			for(k=0;k<4;k++)
			{
				tx=que[head].x+next[k][0];
				ty=que[head].y+next[k][1];
				
				if(tx<0||tx>n-1||ty<0||ty>m-1)
					continue;
				if(a[tx][ty]=='.'&&book[tx][ty]==0)
				{
					sum++;
					book[tx][ty]=1;
					que[tail].x=tx;
					que[tail].y=ty;
					tail++;				
				}
			}
			head++;
		}
		printf("%d\n",sum);
	}
	return 0;
}