数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 50487    Accepted Submission(s): 29750


Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?
 

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input
1573 88 1 0 2 7 4 44 5 2 6 5
 

Sample Output
30
 

Source
 

Recommend
lcy

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#define bug cout <<"bug" <<endl

const int N=100+5;
int dp[N][N];

using namespace std;
typedef long long ll;

int main(void){
    int T;
    cin >> T;
    while(T--){
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=i;j++)   scanf("%d",&dp[i][j]);
        for(int i=n-1;i>=1;i--)
            for(int j=1;j<=i;j++) dp[i][j]+=max(dp[i+1][j],dp[i+1][j+1]);
        printf("%d\n",dp[1][1]);
    }
}