Assign the task
Time Limit: 15000/5000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)

Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

“C x” which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input
1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3

Sample Output
Case #1:
-1
1
2

知识点:(并查集)||(DFS序建树+线段树)

题意:给出一个有向树,初始所有节点为-1.有两种操作,一种为(T,x,y),表示将x节点的所有子树中的节点变为y,另一种为(C,x),为求x节点的值

这个因为涉及到了子树的操作,我们为了快速解决这个问题,所以我们选择用 dfs序 把树的操作转化为区间的操作,然后通过线段树维护区间。

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int N=5e4+10;
int T,n,m,tot,head[N],st[N],ed[N],cnt,ts,vis[N];
struct node{
	int l,r,data;
}t[N<<2];
struct edge{
	int to,next;
}e[N<<1];
void add(int u,int v){
	e[tot].to=v; e[tot].next=head[u]; head[u]=tot++;
}
void dfs(int x){
	st[x]=++cnt;
	for(int i=head[x];~i;i=e[i].next){
		dfs(e[i].to);
	}
	ed[x]=cnt;
}
void push_down(int p){
	if(t[p].data!=-1){
		t[p<<1].data=t[p<<1|1].data=t[p].data;
		t[p].data=-1;
	}
}
void build(int p,int l,int r){
	t[p].l=l,t[p].r=r,t[p].data=-1;
	if(l==r)	return ;
	int mid=l+r>>1;
	build(p<<1,l,mid);	build(p<<1|1,mid+1,r);
}
void change(int p,int l,int r,int x){
	if(t[p].l==l&&t[p].r==r){
		t[p].data=x;	return ;
	}
	push_down(p);
	int mid=t[p].l+t[p].r>>1;
	if(r<=mid)	change(p<<1,l,r,x);
	else if(l>mid)	change(p<<1|1,l,r,x);
	else	change(p<<1,l,mid,x),change(p<<1|1,mid+1,r,x);
}
int ask(int p,int x){
	if(t[p].l==t[p].r)	return t[p].data;
	push_down(p);
	int mid=t[p].l+t[p].r>>1;
	if(x<=mid)	return ask(p<<1,x);
	else	return ask(p<<1|1,x);
}
int main(){
	scanf("%d",&T);
	while(T--){
		tot=cnt=0;	memset(head,-1,sizeof head);	memset(vis,0,sizeof vis);
		scanf("%d",&n);
		for(int i=1,u,v;i<n;i++){
			scanf("%d %d",&u,&v);	add(v,u);	vis[u]++;
		}
		for(int i=1;i<=n;i++){
			if(!vis[i]){
				dfs(i);	break;
			}
		}
		build(1,1,n);
		scanf("%d",&m);
		printf("Case #%d:\n",++ts);
		while(m--){
			char op;	int x,y;	cin>>op;
			if(op=='C'){
				scanf("%d",&x);	printf("%d\n",ask(1,st[x]));
			}else{
				scanf("%d %d",&x,&y);	change(1,st[x],ed[x],y);
			}
		}
	}
	return 0;
}