Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002. 
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input


10 1 
20 1 

10 1 
20 2 
30 1 
-1

Sample Output

20 10 
40 40

题目大意:

输入一个数a,表示接下来有a种物品,数组m和n中分别存储物品的价值和个数,把这些物品分配给A和B,使两个人得到的价值尽可能相等,不相等的情况要保证A得到的价值大于B得到的价值。

C++

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int m[1005],n[1005];
int dp[250010];
int main()
{
    int a,b,c,d,e,f;
    while(cin>>a)
    {
        if(a<0)
            break;
        f=0;
        memset(dp,0,sizeof(dp));
        for(b=0;b<a;b++)
        {
            scanf("%d %d",&m[b],&n[b]);
            f=f+m[b]*n[b];
        }
        e=f/2;
        for(b=0;b<a;b++)
        {
            for(c=0;c<n[b];c++)
            {
                for(d=e;d>=m[b];d--)
                {
                    dp[d]=max(dp[d],dp[d-m[b]]+m[b]);
                }
            }
        }
        printf("%d %d\n",f-dp[e],dp[e]);
    }
    return 0;
}