题目链接:https://pintia.cn/problem-sets/994805046380707840/problems/1111914599412858883
时间限制: 400 ms 内存限制: 64 MB
题目描述
彩票的号码有 6 位数字,若一张彩票的前 3 位上的数之和等于后 3 位上的数之和,则称这张彩票是幸运的。本题就请你判断给定的彩票是不是幸运的。
输入格式
输入在第一行中给出一个正整数 N(≤ 100)。随后 N 行,每行给出一张彩票的 6 位数字。
输出格式
对每张彩票,如果它是幸运的,就在一行中输出 You are lucky!
;否则输出 Wish you good luck.
。
输入样例
2
233008
123456
输出样例
You are lucky!
Wish you good luck.
解题思路
把前三位和后三位分开,判断各个位上的数和是否相等。
/*
*@Author: lzyws739307453
*@Language: C++
*/
#include <bits/stdc++.h>
using namespace std;
int main() {
int a, b, c, d, e, f, t;
scanf("%d", &t);
while (t--) {
scanf("%1d%1d%1d%1d%1d%1d", &a, &b, &c, &d, &e, &f);
if (a + b + c != d + e + f)
printf("Wish you good luck.\n");
else printf("You are lucky!\n");
}
return 0;
}