题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1045
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

Problem solving report:

Description: 在一个最大为4 * 4网格组成的城市里,每个网格可能为“墙壁”(用‘X’表示)和“街道”(用‘.’表示)。现在在街道放置碉堡,每个碉堡可以向上下左右四个方向开火,子弹射程无限远。墙壁可以阻挡子弹。问最多能放置多少个碉堡,使它们彼此不会互相摧毁。
Problem solving: 从起点(0,0)开始一直到(n-1,n-1)遍历每一个点,每个都有放与不放两种情况,并且也要判断每个点是否可以放碉堡。当判断是否可以放的时候,可判断此行此列以前遍历的时候是否放过,往左、上方判断,不必往下、右方判断,因为下面和右边还未遍历。

#include <stdio.h>
int max, n;
char map[5][5];
int Getfind(int x, int y)
{
    int i;
    i = x - 1;
    while (i >= 0 && map[i][y] != 'X') 
        if (map[i--][y] == '#')
            return 0;
    i = y - 1;
    while (i >= 0 && map[x][i] != 'X')
        if (map[x][i--] == '#')
            return 0;
    return 1;
}
void dfs(int k, int step)
{
    int x, y;
    if (k == n * n)
    {
        if (step > max)
            max = step;
        return ;
    }
    x = k / n;
    y = k % n;
    if (map[x][y] == '.' && Getfind(x, y))
    {
        map[x][y] = '#';
        dfs(k + 1, step + 1);
        map[x][y] = '.';
    }
    dfs(k + 1, step);
}
int main()
{
    while (scanf("%d", &n), n)
    {
    	max = 0;
        for (int i = 0; i < n; i++)
            scanf("%s", map[i]);
        dfs(0, 0);
        printf("%d\n", max);
    }
    return 0;
}