How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26139    Accepted Submission(s): 13001


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
2 4
 

Author
Ignatius.L
 

Source


思路:

裸并查集。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<cstdlib>
using namespace std;

int f[1000+5]={0},n,m,k,sum=0;

void init()
{
	for(int i=1;i<=n;i++)f[i]=i;
}

int find(int v)
{
	if(f[v]==v)
		return v;
	else
	{
		f[v]=find(f[v]);
		return f[v];
	}
}

void merge(int v,int u)
{
	int t1,t2;
	t1=find(v);
	t2=find(u);
	if(t1!=t2)
	{
		f[t2]=t1;
	}
}


int main()
{
	int t;
	scanf("%d",&t); 
	while(t--)
	{
		sum=0;
		scanf("%d%d",&n,&m);
		init();
		for(int i=1;i<=m;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			merge(a,b);
		}
		for(int i=1;i<=n;i++)
		{
			if(f[i]==i)
			{
				sum++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}