1043 Is It a Binary Search Tree (25分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11
			

Sample Output 1:

YES
5 7 6 8 11 10 8
			

Sample Input 2:

7
8 10 11 8 6 7 5
			

Sample Output 2:

YES
11 8 10 7 5 6 8
			

Sample Input 3:

7
8 6 8 5 10 9 11
			

Sample Output 3:

NO
			
#include<iostream>
#include<vector>
using namespace std;
struct node
{
	int data;
	node* lchild;
	node* rchild;
};
void insert(node*& root, int x)
{
	if (root == NULL)
	{
		root = new node;
		root->data = x;
		root->lchild = root->rchild = NULL;
	}
	else if (root->data > x)
		insert(root->lchild, x);
	else
		insert(root->rchild, x);
}
vector<int>yi, pre, post, prem, postm;
void preorder(node* root)
{
	if (root == NULL)return;
	pre.push_back(root->data);
	preorder(root->lchild);
	preorder(root->rchild);
}
void premorder(node* root)
{
	if (root == NULL)return;
	prem.push_back(root->data);
	premorder(root->rchild);
	premorder(root->lchild);
}
void postorder(node* root)
{
	if (root == NULL)return;
	postorder(root->lchild);
	postorder(root->rchild);
	post.push_back(root->data);
}
void postmorder(node* root)
{
	if (root == NULL)return;
	postmorder(root->rchild);
	postmorder(root->lchild);
	postm.push_back(root->data);
}
int main()
{
	int n,nod;
	while (cin >> n)
	{
		yi.clear();
		pre.clear();
		post.clear();
		prem.clear();
		postm.clear();
		node* root = NULL;
		for (int i = 0; i < n; i++)
		{
			cin >> nod;
			yi.push_back(nod);
			insert(root, nod);
		}
		preorder(root);
		premorder(root);
		postorder(root);
		postmorder(root);
		if (pre == yi)
		{
			printf("YES\n");
			for (int i = 0; i < n; i++)
			{
				cout << post[i];
				if (i != n - 1)
					cout << " ";
				else
					cout << endl;
			}
		}
		else if (prem == yi)
		{
			printf("YES\n");
			for (int i = 0; i < n; i++)
			{
				cout << postm[i];
				if (i != n - 1)
					cout << " ";
				else
					cout << endl;
			}
		}
		else
			cout << "NO" << endl;
	}
	return 0;
}