题目链接:http://poj.org/problem?id=3259
Time Limit: 2000MS Memory Limit: 65536K

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Problem solving report:

Description: John的农场里field块地,path条路连接两块地,hole个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。
Problem solving: 判断给出的图中是否存在负权环,存在则输出“YES”,否则输出“NO”。输入的路的边权为正,虫洞的边权为负,而Spfa算法思想在求最短路时,只有负权环对其有影响,也就是说可利用Spfa求最短路的入队出队过程判断是否出现负环。

Accepted Code:

#include <cmath>
#include <queue>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 505;
const int MAXM = 5205;
const int inf = 0x3f3f3f3f;
bool vis[MAXN];
int dis[MAXN], inq[MAXN], f[MAXN], cnt;
struct edge {
    int u, v, w;
    edge(int u_ = 0, int v_ = 0, int w_ = 0) : u(u_), v(v_), w(w_) {}
}e[MAXM];
inline void Add(int u, int v, int w) {
    e[++cnt] = edge(f[u], v, w);
    f[u] = cnt;
}
inline void init() {
    cnt = 0;
    memset(f, -1, sizeof(f));
    memset(inq, 0, sizeof(inq));
    memset(dis, 0x3f, sizeof(dis));
    memset(vis, false, sizeof(vis));
}
inline bool Spfa(int s, int n) {
    queue <int> Q;
    Q.push(s);
    dis[s] = 0;
    vis[s] = true;
    while (!Q.empty()) {
        int u = Q.front();
        Q.pop();
        vis[u] = false;
        for (int i = f[u]; ~i; i = e[i].u) {
            int v = e[i].v;
            if (dis[v] > dis[u] + e[i].w) {
                dis[v] = dis[u] + e[i].w;
                if (!vis[v]) {
                    Q.push(v);
                    vis[v] = true;
                }
                if (++inq[v] > n)
                    return true;
            }
        }
    }
    return false;
}
int main() {
    int t, n, m, p, u, v, w;
    scanf("%d", &t);
    while (t--) {
        init();
        scanf("%d%d%d", &n, &m, &p);
        for (int i = 0; i < m; i++) {
            scanf("%d%d%d", &u, &v, &w);
            Add(u, v, w);
            Add(v, u, w);
        }
        for (int i = 0; i < p; i++) {
            scanf("%d%d%d", &u, &v, &w);
            Add(u, v, -w);
        }
        if (Spfa(1, n))
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}