All members of Hulafly love playing the famous network game called 'Lou 1 Zhuang' so much that Super Da Lord got mad with them. So he thought over and over and finally came up with a good idea to stop them. He consulted an ACM master and asked for the hardest problem ever in the world. Hulafly must solve this problem in order to get permission of playing 'Lou 1 Zhuang'. They, however, are so eager to play 'Lou 1 zhuang' and have no interest in this problem at all, so they turn to you for help. You can do this only if you swear that you will never tell Da Lord that you have helped them.
'Lou 1 Zhuang' is a game with only one but a very tall buiding in it and everybody runs a shop in this buiding ---- either a cake shop or a barbershop, each one occupies a whole floor. (Log in at www.xiaonei.com and check details at http://apps.xiaonei.com/soletower/tower.php?origin=2807) Super Da Lord asks that if the buiding is N stories high, how can we devided the floors(or the shops) and multiply the number of floors(or shops) in each part to make the product P as large as possible. Neverthless, Super Da Lord thought that it's still too hard for them, so he gave them some hints, he said:"Go and find the solutoin in 'Lou 1 Zhuang'!"
Given the buidings' height N, you are to find the largest P.
Input
The buidings' height N. (1 <= N <= 10^9)
Output
The product you've found P (mod 2009).
Sample Input
1
2
3
4
Sample Output
1
2
3
4
Hint
Hint
You can apply to be huhupao, flytosky and koala's friends at xiaonei.com.
题意 将n分成若干个数的和,求这些数乘积的最大值
题解:将一个数分解成两个数的和当然是把这个数除以2
所以 结果会有很多2和3
然后2*2*2 又可以换为3*3
所以最后求得是有多少个3,求余剩1的话 就把最后那个1换成4求解 其他不变
#include <bits/stdc++.h>
#define mod 2009
using namespace std;
typedef long long int ll;
int quick_powmod(ll a,ll b,int m)
{
a%m;
ll ans=1;
while(b)
{
if(b&1)
ans=(ans*a)%m;
a=(a*a)%m;
b>>=1;
}
return int(ans);
}
int main()
{
ll n;
while(scanf("%lld",&n)!=EOF)
{
if(n==1)
printf("1\n");
else if(n==2)
printf("2\n");
else
{
int ans=1;
long long p=n/3;
if (n%3==1)
{
ans=4*quick_powmod(3,p-1,mod)%mod;
}
else if(n%3==2)
{
ans=2*quick_powmod(3,p,mod)%mod;
}
else if(n%3==0)
{
ans=1*quick_powmod(3,p,mod)%mod;
}
printf("%d\n",ans);
}
}
return 0;
}