Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1032    Accepted Submission(s): 553


Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn). Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi{+1,1}) and a scaling factor α0 in such a manner that WαB2 is minimum.

Note that denotes the Euclidean norm (i.e. X=x21++x2n, where X=(x1,x2,...,xn)).
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integers n (1n100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (10000wi10000).
 

Output
For each test case, output the minimum value of WαB2 as an irreducible fraction " p/ q" where p, q are integers, q>0.
 

Sample Input
3 4 1 2 3 4 4 2 2 2 2 5 5 6 2 3 4
 

Sample Output
5/1 0/1 10/1
 

Author
zimpha
 

Source



思路:
这个题的题意就是说,给你一个向量W,β可以在-1和+1中间选择,α未知,让你求||W-αβ||的最小值并用分数形式表示。
也就是说,根号(wi-α*βi)最小。因为wi没说明正负,β可以在±1中调,而且这相当于是一个距离问题,所以不妨对wi取绝对值并且把由β把wi调成是和α是同号的。然后就是求||wi|-α|的最小值。
仔细思考,实际上我们的目的就是把这么多个数通过加减一个数使得它们尽量的靠近0,显然,肯定是往平均数的方向加减就可以得到最小值,所以答案就是所有的数与平均数差的平方的和,那么我们把平方拆开,就可以化简得到一个式子:ans = sum1 + sum2*sum2/n     (sum1,sum2分别表示的是平方和以及绝对值的和)。


代码:
#include <cstdio>  
#include <cstring>  
#include <cstdlib>  
#include <iostream>  
#include <algorithm>  
using namespace std;  
typedef long long LL;  
LL gcd(LL a,LL b) {return b?gcd(b,a%b):a;}  
int main()  
{  
    int T;  
    scanf("%d", &T);  
    while(T--)  
    {  
        int n;  
        scanf("%d", &n);  
        LL sum2=0, sum1=0;  
        for(int i=0; i<n; i++)  
        {  
            LL tmp;  
            scanf("%I64d", &tmp);  
            sum2 += abs(tmp);  
            sum1 += tmp*tmp;  
        }  
        LL a = sum1*n - sum2*sum2, b = n;  
        LL g = gcd(a,b);  
        if(g) a /= g,b /= g;  
        printf("%I64d/%I64d\n",a,b);  
    }  
}