题目链接:http://nyoj.top/problem/1253

  • 内存限制:64MB 时间限制:1000ms

题目描述

The fight goes on, whether to store  numbers starting with their most significant digit or their least  significant digit. Sometimes  this  is also called  the  "Endian War". The battleground  dates far back into the early days of computer  science. Joe Stoy,  in his (by the way excellent)  book  "Denotational Semantics", tells following story:

"The decision  which way round the digits run is,  of course, mathematically trivial. Indeed,  one early British computer  had numbers running from right to left (because the  spot on an oscilloscope tube  runs from left to right, but  in serial logic the least significant digits are dealt with first). Turing used to mystify audiences at public lectures when, quite by accident, he would slip into this mode even for decimal arithmetic, and write  things  like 73+42=16.  The next version of  the machine was  made  more conventional simply  by crossing the x-deflection wires:  this,  however, worried the engineers, whose waveforms  were all backwards. That problem was in turn solved by providing a little window so that the engineers (who tended to be behind the computer anyway) could view the oscilloscope screen from the back.
You will play the role of the audience and judge on the truth value of Turing's equations.

输入描述

The input contains several test cases. Each specifies on a single line a Turing equation. A Turing equation has the form "a+b=c", where a, b, c are numbers made up of the digits 0,...,9. Each number will consist of at most 7 digits. This includes possible leading or trailing zeros. The equation "0+0=0" will finish the input and has to be processed, too. The equations will not contain any spaces.

输出描述

For each test case generate a line containing the word "TRUE" or the word "FALSE", if the equation is true or false, respectively, in Turing's interpretation, i.e. the numbers being read backwards.

样例输入

73+42=16
5+8=13
0001000+000200=00030
0+0=0

样例输出

TRUE
FALSE
TRUE

解题思路

题意:机器会将数倒着看,请判断输入的式子是否正确。
思路:把数翻一下,验证正确性就行了。

#include <bits/stdc++.h>
using namespace std;
char str[30];
int Judge(char *str, int l, int r) {
    int ans = 0;
    for (int i = l; i >= r; i--)
        ans = ans * 10 + str[i] - '0';
    return ans;
}
int main() {
    int m, k, len, s[3];
    while (~scanf("%s", str)) {
        len = strlen(str);
        if (len == 5 && str[0] + str[2] + str[4] == 3 * '0')
            break;
        k = m = 0;
        for (int i = 0; i < len; i++) {
            if (str[i] == '+' || str[i] == '=') {
                s[k++] = Judge(str, i - 1, m);
                m = i + 1;
            }
        }
        s[k++] = Judge(str, len - 1, m);
        if (s[0] + s[1] != s[2])
            printf("FALSE\n");
        else printf("TRUE\n");
    }
    return 0;
}