A secret service developed a new kind of explosive that attain its volatile property only when a specific
association of products occurs. Each product is a mix of two different simple compounds, to which we
call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds
creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three
compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.
You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive
binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in
the same room an explosive association. So, after placing a set of pairs, if you receive one pair that
might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you
must accept it.
An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G,
F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the
following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds).
Finally, you would accept the last pair, F+H.
Compute the number of refusals given a sequence of binding pairs.
Input
The input will contain several test cases, each of them as described below. Consecutive
test cases are separated by a single blank line.
Instead of letters we will use integers to represent compounds. The input contains several lines.
Each line (except the last) consists of two integers (each integer lies between 0 and 105
) separated by
a single space, representing a binding pair.
Each test case ends in a line with the number ‘-1’. You may assume that no repeated binding pairs
appears in the input.
Output
For each test case, the output must follow the description below.
A single line with the number of refusals.
Sample Input
1 2
3 4
3 5
3 1
2 3
4 1
2 6
6 5
-1
Sample Output
3

题目大意:有一些简单点的化合物,每个化合物都有两种元素组成,你是一个装箱工人,从实验员那里按照顺序依次把一些简单的化合物装到车上。但是这里存在一个安全隐患:如果车上存在k个化合物,正好包含k中元素,那么他们将组成一个易爆混合物。为了安全起见,当你拿到一个化合物时,如果它和车上化合物形成易爆化合物,你应当拒绝撞车,编程输出由多少个没有撞车的化合物。
思路:
好像是一个裸题,先将元素并起来,如果并起来的元素他们根节点相同,说明车上已经有这两种化合物了,再装上车可能会形成易爆物,这时候计数一下,这个输入格式有点无语。。。。
代码:

#include<iostream>
#define MAXN 100005
using namespace std;

int a,b;
int parent[MAXN];
int ans=0;
void defin()
{
	for(int i=1;i<=MAXN;i++){
		parent[i]=i;
	}
}
int FIND_X(int x)
{
	if(x!=parent[x]){
		parent[x]=FIND_X(parent[x]);
	}
	return parent[x];
}
void UNION_S(int a,int b)
{
	int x=FIND_X(a);
	int y=FIND_X(b);
	    if(x!=y){
			parent[x]=y;
		}else{
			ans++;
		}
}
int main()
{
	while(cin>>a&&a!=-1)
	{
		defin();
		ans=0;
		cin>>b;
		UNION_S(a,b);
		while(cin>>a&&a!=-1){
			cin>>b;
			UNION_S(a,b);
		}
		cout<<ans<<endl;
	}
}